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Einfuhrung

Die ESP32-Cam ist ein sehr wettbewerbsfahiges, kleines Kameramodul, das als
Minimalsystem mit einer BaugroRe von nur 27 x 40,5 x 4,2 mm unabhangig
arbeiten kann.

Es kann in verschiedenen loT-Anwendungen eingesetzt werden. Sie eignet sich
flr Smart-Home-Gerate, industrielle drahtlose Steuerung, drahtlose
Uberwachung, drahtlose QR-Identifikation und andere loT-Anwendungen.
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Spezifikationen
SPI Flash 4 MB
RAM 520KB SRAM + 4M PSRAM
Bluetooth Bluetooth 4.2 BR/EDR and BLE
standards
Wi-Fi 802.11 b/g/n

Support interface

UART, SPI, 12C, PWM

Support TF card Max. 4GB
IO port 9
UART Baudrate Default 115200 bps

Image Output Format

JPEG (OV2640 support only), BMP,
GRAYSCALE

Spectrum Range

2412~2484 MHz

Antenna

Onboard PCB antenna, gain 2dBi

Transmit Power

802.11b: 17+2 dBm (@11Mbps)
802.11g: 14+2 dBm (@54Mbps)
802.11n: 13+2 dBm (@MCS7)

Receiving Sensitivity

CCK, 1 Mbps: -90 dBm

CCK, 11 Mbps: -85 dBm

6 Mbps (72 BPSK): -88 dBm
54 Mbps(% 6-QAM): -70 dBm

MCS7(65 Mbps, 72.2 Mbps): -67 dBm

Power Supply Range

5V

Operating Temperature

-20°C~ 85°C

Dimensions

27 x40.5x4.5 mm
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5V
GND
1012
1013
1015
1014
102
104

Hinweis:

Fk_
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3.3V
1016
100
GND
VCC
UOR
uoT
GND

Das Modul kann entweder tber den 3,3V pin oder liber den 5V pin versorgt

werden.

Es wird empfohlen das Modul iber den 5V pin(mit 5V) zu betreiben.

Der VCC pin ist ein 3,3V ausgang.
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Installation der Arduino IDE

Die kostenlose Arduino IDE Entwicklungsumgebung konnen Sie unter
folgendem Link herunterladen: https://www.arduino.cc/en/Main/Software

Windows Benutzer sollten unbedingt eine der ersten beiden
Download-Optionen fir die Arduino IDE verwenden. Die “Windows App”
Version aus dem Windows Store flihrt insbesondere bei der Verwendung von
Board-Definitionen von Drittanbietern zu Verbindungsproblemen.

Download the Arduino IDE

Windows installer, for Windows XP and up

Windows zIP file for non admin install

ARDUINO 1.X.X Windows apy: “eqiv:cs Win 81 or 10

The open-source Arduino Software (IDE) makes it easy to Get 52

write code and upload it to the board. It runs on

Windows, Mac OS X, and Linux. The environment is .
% written in Java and based on Processing and other open- Mac OS5 X10.8 Mountain Lion or newer

source software.

This software can be used with any Arduino board. Linux 32 bits

Refer to the Getting Started page for Installation Linux &4 bits

nsructions Linux ARM 32 bits

Linux ARM 64 bits

Release Notes
Source Code
Checksums (sha512)

Nach dem Starten der Arduino IDE Installationsdatei
“arduino-1.X.X-windows.exe” missen die Lizenzbedingungen der Software
gelesen und akzeptiert werden:


https://www.arduino.cc/en/Main/Software
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@ Arduino Setup: License Agreement — >

W, Please review the license agreement before instaling Arduing. If you
2.0/ accept all terms of the agreement, did: I Agree.

,"ENU LESSER. GEMERAL PUBLIC LICEMSE Y
Version 3, 29 June 2007
Copyright (C) 2007 Free Software Foundation, Inc, <htto://fsf.org/=

Everyone is permitted to copy and distribute verbatim copies of this license
document, but changing it is not allowed.

This version of the GMU Lesser General Public License incorporates the terms
and conditions of version 3 of the GMU General Public License, supplemented

by the additional permissions listed below. v

Im nachsten Schritt kdnnen unterschiedliche Optionen zur Installation
ausgewahlt werden.

@ Arduine Setup: Installation Options — >

B, Check the components you want to install and unchedk the components
2.0 you don't want to install. Click Mext to continue.

Select components to install: Install Arduino software

Install USE driver

Create Start Menu shortout
Create Desktop shortout
Assodate .ino files

Space reguired: 482, 4MB

Cancel < Back | Mext = |

Es folgt eine kurze Ubersicht der verschiedenen Optionen, mit einer kurzen
Erklarung zu jeder Option:
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Option Erklarung

Install Arduino Software Installiert die Arduino IDE - Diese Option kann
nicht abgewahlt werden

Install USB Driver Installiert USB Treiber fiir verschiedene
andere Microcontroller. Fiir die Verwendung
der Software mit dem D1 mini sind diese nicht
erforderlich, wir empfehlen jedoch unbedingt
die Installation, falls Sie auch andere
Mikrocontroller verwenden

Create Start Menu shortcut | Erstellt eine Verknipfung im Windows
Startmeni (Optional)

Create Desktop shortcut Erstellt eine Verknlpfung auf dem
Arbeitsplatz (Optional)

Associate .ino files Erstellt eine Dateinamenerweiterung fir
Dateien mit der Endung .ino und verknipft
diese mit der Arduino IDE

Zuletzt muss noch der Zielordner angegeben werden. Die Installation bendétigt
ca. 500MB freien Speicherplatz.

I'_F:'J'I Arduine Setup: Installation Folder - >

i Setup will install Arduin in the following folder, To install in a different
.2) folder, dick Browse and select another folder. Click Install to start the
installation.

Destination Folder

Browse... |

Space required: 432.4MB
Space available: 12.9GB

Cancel < Back | Install |

Klicken Sie auf “Install”, um die Installation zu starten.



A-Delivery

Ihr Experte fUr Mikroelektronik!

ESP32-Cam

@ Arduino Setup: Installing —

Extract: avr-c++filt.exe
© E—
Show details

Cancel | Kullsoft Install System v3.0 < Back | Close |

Nach erfolgreicher Installation kann das Installationsprogramm (iber die

Schaltflache “Close” beendet werden:

@ Arduino Setup: Completed —
Completed
& 0] Ipl—
Show details |

Cancel | Kullsoft Install System v3.0 < Back | Close I
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Zusatzliche Einstellungen

Um die ESP32-Cam in der Arduino IDE programmieren zu kdnnen muissen Sie
den Support fur die ESP32-Platform installieren.

Offnen Sie die Arduino IDE und gehen Sie zu: File > Preferences, und finden Sie
das Feld "Additional URLs".

Kopieren Sie folgenden Link:
https://dl.espressif.com/dl/package_esp32_index.json

Preferences

Settings  Network

Sketchbook location:
C:\Users\pc\Documents \Arduino)|

Editor language: System Default « | (requires restart of Arduino)
Editor font size: 18

Interface scale: Automatic | 100 7 % (requires restart of Arduino)

Theme: Default theme  (requires restart of Arduino)

Show verbose output during: [ | compilstion [ upload
Compiler warnings: None

[[] Display line numbers

[ Verify code after upload

] Check for updates on startup

[[] Use accessibility features

[] Enable Code Folding
[[] Use external editor
[~ Save when verifying or uploading

I Additional Boards Manager URLs: Iﬂth:s:,r'.l'dl.esp'Essif.cornfdl,h)ad<age_esp32_index.json

C:\JUsers\pc\AppData'Local\Arduing 15preferences. txt /

oK Cancel
Fugen Sie diesen Link in das Feld "Additional URLs" ein. Wenn Sie bereits
einen oder mehrere Links in diesem Feld haben, fugen Sie einfach ein
Komma nach dem letzten Link ein, fugen Sie den neuen Link nach dem

Komma ein und klicken Sie auf die Schaltflache OK. SchlieBen Sie dann die
Arduino-IDE.

10
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Offnen Sie die Arduino IDE erneut und gehen Sie zu:

Tools > Board > Boards Manager

Es offnet sich ein neues Fenster, geben Sie esp32 in das Suchfeld ein und
installieren Sie das Board mit dem Namen esp32 von Espressif Systems,
wie unten abgebildet:

& Boards Manager X
Type Al v | |esp32
esp32 A

by Espressif Systems
Boards included In this package:!
ESP32 Dev Module, WEMOS LoLin32, WEMOS D1 MINI ESP32.

More Info

L0.4 « Instal

Jetzt konnen Sie unter Tools > Board > ESP32 Arduino > Al-Thinker ESP32-CAM

auswahlen.
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Anschlussdiagramm

Um die ESP32-Cam flashen zu kénnen benotigen Sie einen USB-to-UART
Adapter, stellen Sie sicher dass der dafiir nétige Treiber installiert ist.

Folgend Abbildung zeigt den Anschluss der ESP32-Cam mit dem AZ-Delivery
CH340 Adapter(es kann auch ein anderer Adapter verwendet werden). Der
Jumper fir den Logikpegel muss auf 3,3V gesetzt werden da ansonsten die pins
am ESP Modul beschadigt werden.

m
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-
w
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>
Z

Jumper for BOOT-mode

FT232 ESP32-Cam
VCC 5V

GND GND

™ UOR

RX uoT

Um die ESP32-Cam in den BOOT-Modus zu setzen wird ein Jumper zwischen
|00 und GND benotigt.

Hinweis: Die ESP32-Cam besitzt keinen verpolschutz, achten Sie darauf 5V und
GND nicht zu vertauschen da ansonsten das Modul zerstort wird.

12
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Blink Beispiel

Als erstes Beispiel eignet sich Blink ganz gut. Auf der ESP32-Cam befindet sich
eine flash-light LED, diese ist mit GPIO 4 verbunden.

#tdefine flash 4
void setup() {
pinMode(flash, OUTPUT);

void loop() {
digitalWrite(flash, HIGH);
delay(1000);
digitalWrite(flash, LOW);
delay(1000);

Wahlen Sie unter Tools > Board > ESP32 Arduino > Al-Thinker ESP32-CAM,
und den Port des Adapters aus. Klicken Sie anschlieBend auf “Hochladen”.

Wenn das Hochladen erfolgreich war kdnnen Sie den Jumper zwischen 100 und
GND entfernen und anschlielend die RESET-Taste betatigen. Seien Sie gewarnt,
die Flash-light LED ist sehr hell.

13
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Kamera Webserver Beispiel

Mit diesem Beispiel kann man sich einen Video Stream auf dem Webinterface
anzeigen lassen. Um das Beispiel zu 6ffnen gehen Sie auf
File > examples > ESP32 > camera > CameraWebServer

Ab Zeile 10 soll man das Kamera Modell wahlen. Hier muss das Model
Al-Thinker gewahlt werden. Passen Sie die Zeilen an, es sollte wie folgt
aussehen:

// Select camera model

//#define CAMERA MODEL_ WROVER _KIT // Has PSRAM
//#define CAMERA _MODEL_ESP_EYE // Has PSRAM
//#define CAMERA_MODEL_M5STACK PSRAM // Has PSRAM
//#define CAMERA_MODEL_M5STACK V2 PSRAM // M5Camera
//#define CAMERA MODEL MS5STACK WIDE // Has PSRAM
//#define CAMERA_MODEL_ M5STACK ESP32CAM // No PSRAM
//#define CAMERA_MODEL_ M5STACK UNITCAM // No PSRAM
#define CAMERA MODEL AI THINKER // Has PSRAM
//#define CAMERA MODEL_TTGO T _JOURNAL // No PSRAM

In Zeile 23 und 24 missen Sie noch die SSID und Passwort ihres Routers
eintragen. z.B.:

const char* ssid = "hier-SSID";
const char* password = "Hier-Passwort";

14
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AnschlieBend kann dieses Beispiel Hochgeladen werden. Sobald das hochladen
erfolgreich war, entfernen Sie den jumper zwischen |00 und GND und
betitigen anschlieRend die reset Taste. Offnen Sie den Seriellen Monitor der
Arduino IDE hier sollte die IP-Adresse ausgegeben werden unter der die
ESP32-Cam erreichbar ist.

Geben Sie die IP-Adresse der ESP32-Cam in Ihren Browser ein(Sie missen im
gleichen Netzwerk sein). Jetzt befinden Sie sich auf dem Webinterface der
ESP32-Cam. Es gibt diverse Einstellmoglichkeiten mit denen man sich spielen
kann. Unten gibt es den Button “Start Stream” mit dem kdnnen Sie die
Videoubertragung starten.

15
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Gesichtserkennung

Das vorherige Beispiel liefert auch die Funktion der Gesichtserkennung. Wenn
der Stream lauft kann man die Option “Face detection” aktivieren, in der
Videoansicht wird ein gelbes Rechteck um das Gesicht gelegt. Mit der Option
“Face recognition” und dem Button “Enroll Face” kann ein Gesicht
abgespeichert werden.

Nutzen Sie die aktuelle Version der ESP32 Boardinformationen (zur Zeit 2.0.2)
funktioniert die Gesichtserkennung nicht. Diese Funktion sollte in Zukunft
wieder zur Verfligung stehen.

Um die Gesichtserkennung dennoch nutzen zu kénnen missen Sie die Version
downgraden(eine altere Version installieren). Das kénnen Sie machen indem
Sie auf Tools > Board > Boardmanager gehen. geben Sie “esp32” in die
Suchleiste ein.

16
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Klicken Sie auf “Version auswahlen” und wahlen Sie die Version 1.0.4 aus und
klicken auf “installieren”, starten sie anschlieRend die Arduino IDE neu

@ Boardverwalter X
Typ  Alle ~ | |esp32
esp32 A~

by Espressif Systems Version INSTALLED

In diesem Paket enthaltene Boards:

ESP32 Dev Board, ESP32-52 Dev Board, ESP32-C3 Dev Board.
More Info

Version auswahlen: v | Installieren [s Update Entfernen

A

Ist die Arduino IDE neu gestartet mussen Sie das Beispiel neu o6ffnen. File >
Examples > ESP32 > camera > CameraWebServer

Nehmen Sie die gleichen einstellungen vor wie im vorherigen Beispiel und

laden es auf die ESP32-Cam.
Die Gesichtserkennung funktioniert jetzt.
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Jetzt ist es an der Zeit, zu lernen und eigene Projekte zu erstellen. Das kdnnen
Sie mit Hilfe von vielen Beispielskripten und anderen Tutorials tun, die Sie im

Internet finden konnen.

Wenn Sie auf der Suche nach den qualitativ hochwertigen Produkten fiir
Arduino und Raspberry Pi sind, sind Sie bei der AZ-Delivery Vertriebs GmbH
genau richtig. Sie erhalten zahlreiche Anwendungsbeispiele, vollstindige
Installationsanleitungen, eBooks, Bibliotheken und Unterstiitzung durch

unsere technischen Experten.

https://az-delivery.de

Viel Spal3!

Impressum

https://az-delivery.de/pages/about-us
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